Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#45 closed task (fixed)

Train run (de: Zugfahrt)

Reported by: susanne.wunsch Owned by: vasco.kolmorgen
Priority: normal Component: Tabular TT Viewer
Version: 1.0 Keywords:
Cc: birgit.jaekel, martin.lehnert

Description

In order to show a train in tabular and/or graphical timetable, please consider train and trainPart. That means in detail:

  • The passenger view fulfills the needs for tabular timetable: look only at train/@type="commercial".
  • The signalman view fulfills the needs for the graphical timetable: look only at train/@type="operational".
  • Consider each train/trainPartSequence in order to show the full run of the train, nevertheless it's an operational or a commercial train.
  • Provide train/@trainNumber to the customer, in order to choose and/or filter for certain trains.

Change History (3)

comment:1 Changed 5 years ago by susanne.wunsch

  • milestone changed from 4. Meeting to next meeting

At the railML-timetable-workgroup-meeting (2015-03-16, Vienna) other developers confirmed this point of view. It reflects the forseen usage of the railML elements.

On the other hand, the current railML developers admitted, that their software tools also show tabular timetables for operational trains and graphical timetables for commercial trains.

Showing different (commercial and operational) trains in tabular and graphical timetable may be a bit confusing because of small differences in times.

comment:2 Changed 5 years ago by susanne.wunsch

  • Resolution set to fixed
  • Status changed from new to closed

See #48 for extended visualization.

comment:3 Changed 4 years ago by vasco.kolmorgen

  • milestone next meeting deleted

Milestone deleted

Note: See TracTickets for help on using tickets.